Blackboard Mobile App Login Issues

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved, and it was observed that clients are operating normally.
Posted May 02, 2025 - 09:43 EDT

Monitoring

Our Technical Team has fixed the issue. Observed that clients are operating normally, and we are monitoring the results.
Posted Apr 30, 2025 - 18:19 EDT

Investigating

Users trying to access the Blackboard mobile app on Android or iOS devices are experiencing issues logging in. We are investigating the issues and will provide updates as soon as they are available. Thank you for your patience as we investigate this issue.
Posted Apr 30, 2025 - 15:03 EDT
This incident affected: Global (Blackboard - Mobile Services - Global), Asia Pacific (Blackboard – Mobile Services – Asia Pacific), Europe & Middle East (Blackboard – Mobile Services – Europe), and Americas (Blackboard – Mobile Services - Americas).