SafeAssign - Processing Time
Incident Report for Blackboard Inc.
Resolved
The SafeAssign backlog has been processed.
Posted Mar 23, 2021 - 04:28 EDT
Monitoring
Due to the high load of submissions, currently, there is a backlog to be processed and the expected waiting time is around 11 hours.
Posted Mar 22, 2021 - 10:44 EDT
This incident affected: Global (SafeAssign).