Blackboard Community Site Login Issues
Incident Report for Blackboard Inc.
Resolved
Initial login issues with Blackboard Community Site have been resolved as of July 14, 2020. We are continuing to investigate the cause of the issue.
Posted Jul 20, 2020 - 09:18 EDT
Update
Users can now log into the Blackboard Community Site again. We are continuing to investigate the cause of the issue.
Posted Jul 14, 2020 - 11:02 EDT
Investigating
We are currently experiencing server connectivity issues with our Blackboard Community site login functionality resulting in users not being able to access the Blackboard Community at this time. The Blackboard team is actively working on this issue.
Posted Jul 14, 2020 - 09:09 EDT
This incident affected: Americas (BB Comms HQ (Formerly ParentLink)).