New user registration
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 18:17 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 08, 2020 - 08:27 EDT
Identified
We are currently experiencing issues with the site resulting in users not being able to register to the Blackboard Community at this time. The Blackboard team is actively working on this issue. Sorry for the inconvenience, but we hope to have this resolved soon.
Posted Sep 08, 2020 - 08:26 EDT
This incident affected: Global (Blackboard Community (Website)).