SafeAssign - Backlog processing
Incident Report for Blackboard Inc.
Resolved
The backlog has been processed.
Posted Nov 24, 2020 - 08:44 EST
Monitoring
Due to the high load of submissions, currently, there is a backlog to be processed and the expected waiting time is around 6 hours.
Posted Nov 23, 2020 - 02:54 EST
This incident affected: Global (SafeAssign).