BB Comms Degraded Performance
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Sep 18, 2020 - 18:00 EDT
Investigating
A subset of Blackboard Mass Notifications clients are currently experiencing a delay in processing automated attendance and demographic imports of up to one hour. These messages and imports are still being sent/processed, but with the aforementioned possible delay. Our development team is working diligently to resolve this issue as soon as possible.
Posted Sep 18, 2020 - 13:59 EDT