Phone Message and Reporting Delay
Incident Report for Blackboard Inc.
Resolved
This issue has been resolved and all stuck messages have been delivered to recipients.
Posted May 24, 2021 - 15:39 EDT
Identified
Our development team has been alerted to several issues we are experiencing with Connect. The team is focused on resolving these issues as soon as possible, and improvements are being made.
Phone
Phone calls are being delayed in sending.
Email
In reviewing our systems, emails are being sent but the reporting that you see is not being updated as expected.
SMS
Individual SMS messages are being delivered, however our reporting is not correctly representing this. SMS messages combined with voice messages are being delayed

Delivery of phone calls continues to improve, but if you have a need to get out a priority call immediately, please call the Connect Support team and they can assist you with an alternative path forward until this is fully resolved.
Posted May 24, 2021 - 14:00 EDT
This incident affected: Americas (Connect - Connect 5).