Learn - SaaS Deployment for Blackboard Learn (Europe) Service Interruption
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.

2020-11-14 18:51:27 GMT
Internet connection caused multiple clients to experience ~14 minute outage.
Posted Nov 14, 2020 - 14:07 EST
Investigating
2020-11-14 18:37:27 GMT
Multiple sites have been reported down. We are currently investigating this issue.

Additional updates will be posted to status.blackboard.com
Posted Nov 14, 2020 - 13:50 EST
This incident affected: Europe, Middle East & Africa (Learn - SaaS Deployment for Blackboard Learn (Europe)).