SMS Delivery Failure
Incident Report for Blackboard Inc.
Resolved
The SMS delivery issue we experienced this morning has been resolved by our vendor. Unfortunately in the process of fixing this, some duplicate SMS messages were attempted, and recipients may have received multiple copies of the same message. This has now been resolved; future SMS messages will NOT receive multiple deliveries. We apologize for any inconvenience this may have caused.
Posted Feb 26, 2021 - 11:23 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 26, 2021 - 10:42 EST
Identified
Blackboard Mass Notification is currently experiencing an SMS messaging service interruption. We are currently working with our providers to resolve this issue quickly. If you need to communicate to your audience before this issue is resolved, please consider using other communication methods, such as phone and email, in the meantime.
Posted Feb 26, 2021 - 10:09 EST