Blackboard Mass Notifications degraded performance and reporting issue
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Aug 31, 2021 - 18:39 EDT
Investigating
Blackboard Mass Notifications is currently experiencing severe service degradation impacting product load times and general responsiveness (generating errors, timing out, etc.) preventing message creation.

Previously created messages are successfully being delivered regardless of message tracking status. We are diligently working on a solution.
Posted Aug 31, 2021 - 17:50 EDT
This incident affected: Americas (BB Comms HQ (Formerly ParentLink)).