Inbound support phone lines appear unresponsive
Incident Report for Blackboard Inc.
Resolved
Agents for all three products are again able to receive inbound support calls. Our apology for any inconvenience.
Posted May 26, 2021 - 18:42 EDT
Investigating
We are currently investigating a potential data center issue affecting the ability of support teams to take incoming phone calls. While we investigate, cases can be submitted via behind the blackboard, or to wcmsupport@blackboard.com, bbcommssupport@blackboard.com, or connectsupport@blackboard.com, as appropriate.

In case of an emergency, please do be sure to include a contact number via which we can reach you.

(update, 6:20 ET - some WCM and BBComms agents are again able to answer inbound support calls, but this is not yet true of of the Connect team)
Posted May 26, 2021 - 17:13 EDT
This incident affected: Americas (BB Comms HQ (Formerly ParentLink), Connect - Connect 5, Web Community Manager (formerly Schoolwires)).