Multiple sites down from US_EAST 1
Incident Report for Blackboard Inc.
Resolved
Sites have been auto recovered.
Posted Sep 07, 2022 - 13:58 EDT
Investigating
Multiple sites down from US_EAST 1, Webtech and Devops teams are investigating this issue.

Additional updates will be posted to status.blackboard.com
Posted Sep 07, 2022 - 13:39 EDT