Partial Service Disruption
Incident Report for Blackboard Inc.
Resolved
The issue with Ultra environments in EU has been identified and resolved.
Posted Jun 25, 2020 - 06:59 EDT
Investigating
We are receiving reports of intermittent issues with Ultra client environments in EU. Teams are engaged and investigating.
Posted Jun 25, 2020 - 04:47 EDT
This incident affected: Europe, Middle East & Africa (Learn - SaaS Deployment for Blackboard Learn (Europe)).