Learn - Mobile Services - Global

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved and observed that clients are operating normally.
Posted Aug 29, 2023 - 08:33 EDT

Update

Several of the affected systems have recovered with a fix and observed that clients are operating normally and will provide updates as we work toward full recovery.
Posted Aug 29, 2023 - 05:13 EDT

Update

Temporary fix has been implemented, we are continue to monitor the results.
Posted Aug 28, 2023 - 21:26 EDT

Monitoring

A temporary fix has been implemented, We are monitoring the results.
Posted Aug 28, 2023 - 15:03 EDT

Update

Fix has been implemented in lower environment and teams are testing it. Our Engineering teams are working on fix.
Posted Aug 28, 2023 - 13:29 EDT

Update

Our Engineers are continuing to work on a fix for this issue and We will share the ETA once available.
Posted Aug 28, 2023 - 11:24 EDT

Identified

The cause of the issue has been identified. Our Engineering teams are working to implement a fix.
Posted Aug 28, 2023 - 10:14 EDT

Investigating

We regret to inform our users that we've identified a technical glitch in our mobile app, leading to CPU challenges and occasional crashes across various regions. Our dedicated team is already actively addressing this, employing all measures to diagnose and rectify the issues swiftly. We understand the importance of uninterrupted service and sincerely apologize for any inconvenience this might cause. Your seamless user experience remains our top priority. We deeply appreciate your understanding and patience as we work towards a prompt resolution.
Posted Aug 28, 2023 - 09:33 EDT
This incident affected: Asia Pacific (Blackboard – Mobile Services – Asia Pacific), Europe & Middle East (Blackboard – Mobile Services – Europe), and Americas (Blackboard – Mobile Services - Americas).