Learn - SaaS Deployment for Blackboard Learn (US)
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 18:24 EDT
Investigating
This incident has been resolved. Multiple clients experienced a network issue.
Posted Jul 17, 2020 - 18:23 EDT
This incident affected: Americas (Learn - SaaS Deployment for Blackboard Learn (US)).