Community Site
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Jan 04, 2022 - 15:38 EST
Investigating
We are aware of an issue with the Community Site and are working with the vendor on a resolution.
Posted Jan 04, 2022 - 15:28 EST
This incident affected: Global (Blackboard Community (Website)).