SafeAssign - Processing time delay
Incident Report for Blackboard Inc.
Resolved
The backlog has been processed.
Posted Oct 14, 2020 - 12:18 EDT
Monitoring
Due to the high load of incoming papers, currently, there is a backlog to be processed and the expected waiting time is around 6 hours.
Posted Oct 13, 2020 - 06:23 EDT
This incident affected: Global (SafeAssign).