Mobile Service Partial Outage - Americas
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted May 14, 2020 - 14:25 EDT
Investigating
The Blackboard and Instructor apps are experiencing intermittent errors in North, Central, and South America (excluding Canada).
Posted May 14, 2020 - 13:43 EDT
This incident affected: Global (Learn - Mobile Services - Global).