Product Learn - Performance issue - US East region
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved and it was observed that clients are operating normally.
Posted Sep 23, 2024 - 03:15 EDT
Monitoring
We have deployed some further fixes and are seeing improvements. We are continuing to monitor for any further issues.
Posted Sep 23, 2024 - 02:07 EDT
Update
Several of the affected systems have recovered and work continues with the remaining environments that are still experiencing performance degradation.
Posted Sep 23, 2024 - 00:47 EDT
Update
Our engineering team is looking into the issue and trying to find a solution. As we make progress, we'll update this page.
Posted Sep 22, 2024 - 23:11 EDT
Update
Our dedicated team is already actively addressing the performance issue, We are employing all measures to swiftly diagnose and rectify the issues. We understand the importance of uninterrupted service and sincerely apologize for any inconvenience this might cause. We will provide the next update by 11:00 PM ET.
Posted Sep 22, 2024 - 21:43 EDT
Update
Our engineering team is continuing to work on a fix for this issue. We appreciate your patience as we work to resolve this. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Sep 22, 2024 - 20:26 EDT
Update
Our engineers are continuing to work towards a fix for this performance issue. At this time, clients may still see slowness while accessing the application. We will provide another update within 30 minutes or as soon as more information becomes available.
Posted Sep 22, 2024 - 19:42 EDT
Identified
Several of the affected systems have recovered and work continues with the remaining environments that are still experiencing performance degradation.
Posted Sep 22, 2024 - 19:09 EDT
Investigating
A sub-set of systems in the US East region are facing performance issues. Our teams are currently investigating this.
Posted Sep 22, 2024 - 18:40 EDT
This incident affected: Americas (Learn - SaaS (US)).