Learn - Mobile Services - Global
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved and observed that clients are operating normally.
Posted Mar 07, 2023 - 08:13 EST
Monitoring
Our Engineering Team has fixed the issue in the affected regions and we are monitoring the results.
Posted Mar 07, 2023 - 07:54 EST
Investigating
There are problems when searching and navigating in the Blackboard App, We are working on fixing the issue and analyzing the root cause.
Posted Mar 07, 2023 - 07:12 EST
This incident affected: Global (Learn - Mobile Services - Global).