Learn Mobile Services – Americas – Degraded Performance
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 13:09 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 24, 2020 - 13:09 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 24, 2020 - 12:37 EDT
Investigating
The Blackboard and Blackboard Instructor apps are experiencing intermittent errors in the Americas.
Posted Jul 24, 2020 - 12:31 EDT
This incident affected: Americas (Learn – Mobile Services - Americas).