Emails issue for Gov Sites - US region

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 12:58 EDT

Update

Our engineers are still investigating the issue to understand its full impact and find a solution. We don't have an ETA for a fix yet.
Posted Jul 16, 2025 - 10:00 EDT

Investigating

Learn instances in US Gov Cloud are unable to send emails due to misconfiguration with email relay services. The issue is currently under investigation.
Posted Jul 14, 2025 - 13:00 EDT
This incident affected: Americas (Blackboard – SaaS Gov Cloud (US)).