Learn SaaS Email service issue: Global

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Feb 23, 2026 - 09:35 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 23, 2026 - 01:57 EST

Identified

We have identified the issue and continuing to work on a fix for this issue. We will share an ETA as soon as it becomes available.
Posted Feb 23, 2026 - 01:04 EST

Investigating

We are aware of the email issue that users are encountering while sending emails from Blackboard. Our teams are investigating this on priority to have this addressed as soon as possible.
Posted Feb 23, 2026 - 00:10 EST
This incident affected: Global (Blackboard - SaaS - Global).