Ally is Experiencing Some Processing Delays US
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Oct 09, 2020 - 16:29 EDT
Investigating
We are currently investigating this issue.
Posted Oct 09, 2020 - 11:01 EDT
This incident affected: Americas (Ally - North America).