Few Blackboard SaaS clients are facing performance issue

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 00:33 EDT

Update

The issue has been resolved.
Posted Jul 02, 2026 - 17:08 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 10:44 EDT

Identified

We have identified the query causing the performance issue. The team is actively working on a fix
Posted Jul 02, 2026 - 09:14 EDT

Investigating

A few Blackboard LMS clients are currently experiencing performance issues. The team is investigating the root cause and working to restore normal performance.
Posted Jul 02, 2026 - 08:39 EDT
This incident affected: Americas (Blackboard - SaaS (US)) and Asia Pacific (Blackboard - SaaS (Asia Pacific)).