Accreditation & Program Review Errors

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 15:17 EDT

Investigating

We are aware of errors displaying in Accreditation & Program Review when attempting to edit standards or generate Offline Reports. The Development Team are working to resolve this issue.
Posted Jul 16, 2026 - 14:18 EDT
This incident affected: Institutional Effectiveness (Accreditation, Program Review).