Learn SaaS - Performance Issue - Global
Incident Report for Blackboard Inc.
Monitoring
Several of the affected systems have recovered with a fix, and we are monitoring the results.
Posted Oct 20, 2024 - 20:14 EDT
Update
We are continuing to work on a fix for this issue. We will provide another update by 9:00 PM EDT.
Posted Oct 20, 2024 - 19:25 EDT
Update
The cause of the issue has been identified. We are actively working on multiple parallel paths to mitigate this issue. We will provide another update within 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2024 - 18:18 EDT
Update
Our dedicated team is already actively addressing the performance issue. We are employing all measures to swiftly diagnose and rectify the issues. We understand the importance of uninterrupted service and sincerely apologize for any inconvenience this might cause.
Posted Oct 20, 2024 - 17:41 EDT
Identified
Our engineers are continuing to work towards a fix for this performance issue. At this time, clients may still see slowness while accessing the application. We will provide another update within 30 minutes or as soon as more information becomes available.
Posted Oct 20, 2024 - 16:49 EDT
Investigating
A subset of systems in the US-East-1 and EU-Central-1 regions is experiencing performance issues. Our teams are investigating this.
Posted Oct 20, 2024 - 16:06 EDT
This incident affects: Global (Learn - SaaS - Global).