Learn SaaS Performance Issues

Incident Report for Blackboard Inc.

Resolved

The incident has been resolved.
Posted Feb 10, 2025 - 08:10 EST

Monitoring

The off-cycle release of 3900.110.0 to production environments is underway.
Posted Feb 07, 2025 - 22:23 EST

Update

Implementation of the fix is complete and release preparation is underway. Updates will begin soon.
Posted Feb 07, 2025 - 19:10 EST

Identified

The issue has been identified and a fix is underway. We expect to begin an off-cycle update of 3900.110.0 to production environments later today.
Posted Feb 07, 2025 - 13:37 EST

Investigating

Some clients have reported performance issues post upgrade to 3900.110 in SaaS Production environments. We are actively working on a resolution and will provide updates as they are available.
Posted Feb 07, 2025 - 11:48 EST
This incident affected: Africa (Blackboard - SaaS (Africa)), Asia Pacific (Blackboard - SaaS (Asia Pacific)), Europe & Middle East (Blackboard - SaaS (Europe)), and Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)).