Blackboard Mass Notifications reporting issue
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Sep 01, 2021 - 12:18 EDT
Investigating
Blackboard Mass Notifications is currently experiencing service degradation impacting message tracking; please be assured messages are being delivered as expected.

We are working diligently on a solution.
Posted Aug 31, 2021 - 19:01 EDT
This incident affected: Americas (BB Comms HQ (Formerly ParentLink)).