The deployment of Blackboard SaaS 4000.21.0 Feature Release to Production environments is being postponed. A new maintenance event will be scheduled once a new release date is confirmed.
Posted Aug 06, 2026 - 11:31 EDT
Update
Due to an issue encountered during internal testing, the release of 4000.21.0 to Production environments will be delayed. Additional information on timing of this release will be provided as soon as available.
DATE SHOWN IS AN ESTIMATE ONLY. ACTUAL RELEASE DATE WILL BE PROVIDED AS SOON AS IT HAS BEEN DETERMINED.
Posted Aug 05, 2026 - 11:14 EDT
Scheduled
Blackboard will be deploying the Blackboard SaaS 4000.21.0 Feature Release to Production environments.
Scheduled for August 6, 2026
Posted Aug 04, 2026 - 13:39 EDT
This scheduled maintenance affected: Africa (Blackboard - SaaS (Africa)), Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)), Europe & Middle East (Blackboard - SaaS (Saudi), Blackboard - SaaS (Europe)), and Asia Pacific (Blackboard - SaaS (Asia Pacific)).