Illuminate - SSO login issue

Incident Report for Blackboard Inc.

Resolved

The issue has been resolved and users should now be able to log in to Illuminate without issues.
Posted Mar 18, 2026 - 09:19 EDT

Investigating

We are currently experiencing an issue with Single Sign-On that may prevent some users from logging in to Illuminate across all regions. We are actively working to resolve it.
Posted Mar 18, 2026 - 08:53 EDT
This incident affected: Global (Illuminate).