Learn SaaS - US-EAST-1 Region - Multiple Sites Inaccessible

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 02:37 EDT

Monitoring

Our service provider implemented a fix, resulting in the recovery of multiple services. We have observed clients operating normally and are continuing to monitor the results.
Posted Oct 20, 2025 - 17:14 EDT

Update

Several affected systems have recovered. Our service provider is continuing work to resolve the performance degradation issues in the remaining environments.
Posted Oct 20, 2025 - 15:52 EDT

Update

We're continuing to see signs of recovery, but full restoration is still in progress. Our teams are working actively with our service provider to resolve the outstanding issues. We will provide our next full update by 3:30 PM EDT or sooner.
Posted Oct 20, 2025 - 14:37 EDT

Update

We are observing partial service recovery. We are still engaged with our service provider to address the remaining affected services. We sincerely apologize for the ongoing disruption and any inconvenience. Our next update is expected by 2:30 PM EDT or Sooner.
Posted Oct 20, 2025 - 13:16 EDT

Update

We are aware the issue is still impacting service. We're collaborating closely with our service provider and will provide our next update by 1:00 PM EDT or sooner if we have additional information.
Posted Oct 20, 2025 - 11:37 EDT

Update

We are still actively engaged with our service provider on mitigation efforts. We appreciate your patience and will provide an ETA as soon as it is confirmed.
Posted Oct 20, 2025 - 10:10 EDT

Identified

We are continuing to work closely with our service provider to resolve the issue. We will share an ETA as soon as it becomes available.
Posted Oct 20, 2025 - 09:33 EDT

Investigating

We are experiencing intermittent issues caused by a widespread AWS outage. Our engineers are engaged in mitigation efforts with the service provider. We regret the disruption and are working to resolve this as quickly as possible.
Posted Oct 20, 2025 - 09:04 EDT
This incident affected: Americas (Blackboard - SaaS (US), BB Annotate).