Verification is currently underway for this update.
Posted Mar 27, 2025 - 06:55 EDT
Update
The Bb Annotate update will resume today (March 26) at 1PM EST. It has been determined that the document rendering issue (which is still under investigation) is not related to Bb Annotate.
Posted Mar 26, 2025 - 10:04 EDT
Update
The Bb Annotate update will continue to be paused while investigating an intermittent Document Rendering issue.
Posted Mar 25, 2025 - 11:23 EDT
Update
This update has been paused due to an internal review and will resume tomorrow (Tuesday, March 25) at 1 PM EST.
Posted Mar 24, 2025 - 14:02 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 24, 2025 - 13:00 EDT
Scheduled
Bb Annotate will be updated on March 24, 2025, starting at 1 PM EST. As part of this update, the Document Engine will be upgraded from version 1.4.4 to 1.4.5. This release includes general improvements and optimizations to enhance performance and reliability.
Customers in Asia, Australia , New Zealand, and the Middle East will be affected.
Posted Mar 20, 2025 - 07:44 EDT
This scheduled maintenance affected: Global (BB Annotate).