Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 24, 2026 - 10:30 EDT
Scheduled
Bb Annotate will be updated via a phased regional roll-out beginning July 24. This release includes performance and reliability improvements. Each region will have a brief maintenance window during which annotation may be affected — the service itself remains available outside these windows.
What to expect during your region's window: During the upgrade window for your region, instructors annotating a document may see slow document rendering and may be temporarily unable to add comments. No annotation data will be lost. Normal performance resumes once the update completes for your region.
The schedule will be as follows: -APAC: Friday, July 24, 10:30 AM EDT (UTC: Friday, July 24, 2:30 PM) -EMEA: Sunday, July 26, 11:30 PM EDT (UTC: Monday, July 27, 3:30 AM) -US & Canada: Tuesday, July 28, 11:30 PM EDT (UTC: Wednesday, July 29, 3:30 AM)
Posted Jul 22, 2026 - 08:35 EDT
This scheduled maintenance affected: Global (BB Annotate).