Site down for a subset of clients.
Incident Report for Blackboard Inc.
Resolved
Our development team has resolved this issue. All services are working as expected once more
Posted Oct 15, 2021 - 13:06 EDT
Investigating
Our development team has identified an issues causing a subset of clients to be unable to use the mass notification system. We are working as quickly as possible to restore all services. If you require an emergency message to be sent and cannot access the system, please reach out to the support team for assistance.
Posted Oct 15, 2021 - 10:13 EDT
This incident affected: Americas (BB Comms HQ (Formerly ParentLink)).