Ally Immersive Reader Alternative Format Issue - Global issue

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 15:09 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2025 - 12:52 EST

Investigating

Ally Immersive Reader Alternative Format Issue - Ally is currently experiencing an issue globally where attempting to download Immersive Reader alternative formats is resulting in an error. Our teams are currently investigating this. All other Ally components remain operational.
Posted Nov 14, 2025 - 10:50 EST
This incident affected: Americas (Ally - Canada, Ally - North America), Asia Pacific (Ally - Asia Pacific, Ally - Australia), and Europe & Middle East (Ally - Europe).