Behind the Blackboard URL Failure
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted May 28, 2021 - 17:28 EDT
Identified
After the maintenance today we have identified that the URL behind.blackboard.com is not redirecting properly to the login page. We are working on resolving this issue. In the meantime please use the direct URL https://blackboard.secure.force.com/ to log in.
Posted May 28, 2021 - 16:06 EDT
This incident affected: Global (Behind The Blackboard).