SafeAssign-Global issue
Incident Report for Blackboard Inc.
Resolved
Our engineers have monitored the fix and confirmed that the service is working as expected.
Posted Jul 17, 2024 - 05:58 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 17, 2024 - 05:41 EDT
Investigating
We have received reports regarding intermittent access to SafeAssign. Our team is actively investigating this issue to identify and resolve the underlying cause.
Posted Jul 17, 2024 - 05:17 EDT
This incident affected: Global (SafeAssign).