Mass Notifications: System slowness for a subset of clients
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 11:06 EST
Identified
For a subset of our clients, they may experience slowness in response of the system. Our team is aware of this issue and working towards a resolution. While we understand that this is not a workaround or solution, we have found that waiting five minutes and retrying can provide an improved experience.
Posted Jan 23, 2023 - 10:17 EST