Learn Saas Outage - US Service Interruption
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved and sites restored.
Posted Dec 01, 2021 - 14:51 EST
Investigating
We are currently experiencing a service interruption for a subset of clients in the US East Region. We have identified the root cause of the issue and working toward resolution. Additional updates will be posted to status.blackboard.com
Posted Dec 01, 2021 - 14:48 EST
This incident affected: Americas (Learn - SaaS (US)).