Bb Annotate down - AP-SOUTHEAST-1 Region

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved and it was observed that clients are operating normally.
Posted Jun 20, 2025 - 07:14 EDT

Monitoring

Our engineers have monitored the fix and confirmed the issue with Bb Annotate has been resolved. All services are now operating normally at this time.
Posted Jun 20, 2025 - 05:43 EDT

Update

Our engineering team is still investigating the issue with Bb Annotate. We will provide a new update as soon as it is available.
Posted Jun 20, 2025 - 02:55 EDT

Investigating

We are aware that some customers hosted out of Singapore are currently unable to access Blackboard Annotate Assignments. Teams are currently investigating.
Posted Jun 20, 2025 - 02:08 EDT
This incident affected: Global (BB Annotate).