Ally Processing Delays on October 20, 2025 - US Region

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 08:35 EDT

Monitoring

Ally is currently experiencing intermittent delays in US-east due to the Amazon Web Services (AWS) outages early this morning. The initial AWS outage occurred between 3:11 AM ET and 5:22 AM ET during which Ally was not able to process all content.

Ally and its associated components remain available, however there may be delays in processing new content, Institutional Reporting and Course Report updates as processes catch up. The Ally development team continues to monitor this as a high priority and we will provide an update when processing queues return to normal levels.
Posted Oct 20, 2025 - 08:21 EDT
This incident affected: Americas (Ally - North America).