Mailings Currently Unavailable - Evaluate, Institutional Effectiveness, Milestone, Portfolio, Course Evaluations

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 13:34 EDT

Investigating

All messaging capabilities are currently down. We will advise as soon as they are operational.
Posted Aug 03, 2026 - 10:49 EDT
This incident affected: Institutional Effectiveness (Accreditation, Program Review, Planning, Outcomes) and Evaluate, Milestone, Portfolio, Course Evaluations.