Help Pages Unavailable
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Jan 27, 2024 - 11:23 EST
Investigating
We are aware of an issue with the help site at https://help.blackboard.com/. When you attempt to access some pages, you receive a message that says "Temporarily Unavailable." We are actively working on a resolution and will provide updates as they are available.
Posted Jan 26, 2024 - 09:31 EST
This incident affected: Global (Blackboard Help (Website)).