Blackboard Audio and Video Feedback Issues

Incident Report for Blackboard Inc.

Resolved

The issue has been resolved.
Posted Apr 24, 2026 - 19:29 EDT

Investigating

Faculty are receiving an "Upload failed" error message when they try to add video or audio feedback on a quiz in the Overall Feedback area for their students. The upload process fails at the final stage. This has been confirmed across multiple users and different media types.

Browsers: Verified on latest versions of Chrome; persists after clearing cache, cookies, and restarting systems.
Error Message: "Upload Failed" appears on the progress bar in the Video Details pane.
Posted Apr 24, 2026 - 17:19 EDT
This incident affected: Africa (Blackboard - SaaS (Africa)), Americas (Blackboard - SaaS (US), Blackboard – SaaS Gov Cloud (US)), Europe & Middle East (Blackboard - SaaS (Saudi), Blackboard - SaaS (Europe)), and Asia Pacific (Blackboard - SaaS (Asia Pacific)).