A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2025 - 10:06 EST
Identified
The issue has been identified and a fix is being implemented. No ETA available as of now and will provide the next update by 10.30 AM ET.
Posted Nov 18, 2025 - 09:37 EST
Update
We are continuing to work closely with our service provider to resolve the issue. No ETA available as of now and will provide the next update by 9.30 AM ET.
Posted Nov 18, 2025 - 08:38 EST
Update
We are continuing to work closely with our service provider to resolve the issue. We will share an ETA as soon as it becomes available.
Posted Nov 18, 2025 - 07:50 EST
Investigating
We are experiencing intermittent issues due to an ongoing outage with our service provider. Our engineers are actively engaged in mitigation efforts alongside the provider to resolve this. We apologize for the disruption and are working for a swift resolution.
Posted Nov 18, 2025 - 06:55 EST
This incident affected: Global (Blackboard - SaaS - Global).