Status Update – Blackboard Attendance

Incident Report for Blackboard Inc.

Identified

The issue has been identified, and a remediation is in progress. We will continue to monitor the situation and provide updates as information becomes available.
Posted Sep 21, 2026 - 18:03 EDT

Update

Blackboard Platform and Ops teams have been engaged as we continue to investigate the issue.
Posted Sep 21, 2026 - 15:11 EDT

Investigating

Some customers are currently experiencing Oops errors when accessing Blackboard Attendance.

We are investigating the issue and will provide further updates as more information becomes available
Posted Sep 21, 2026 - 11:42 EDT
This incident affects: Africa (Blackboard - SaaS (Africa)), Americas (Blackboard - SaaS (US)), Europe & Middle East (Blackboard - SaaS (Saudi), Blackboard - SaaS (Europe)), and Asia Pacific (Blackboard - SaaS (Asia Pacific)).