Learn - Mobile Services - Global

Incident Report for Blackboard Inc.

Resolved

This incident has been resolved.
Posted Feb 06, 2024 - 06:10 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2024 - 06:05 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 06, 2024 - 05:43 EST

Investigating

We are currently experiencing application slowness in our Mobile Applications. Our dedicated team is already actively addressing this, employing all measures to diagnose and rectify the issues swiftly. We understand the importance of uninterrupted service and sincerely apologize for any inconvenience this might cause.
Posted Feb 06, 2024 - 05:36 EST
This incident affected: Global (Blackboard - Mobile Services - Global).