WCM phone support capacity degraded
Incident Report for Blackboard Inc.
Resolved
Normal phone service for Web Community Manager support has been restored.
Posted Feb 22, 2021 - 09:12 EST
Investigating
As of roughly 1PM Eastern time on Friday 2/19, Web Community Phone support has experienced an issue preventing most agents from receiving calls. Our telecom team is working to resolve this issue, but in the meantime you may find it more efficient to open a case via Behind the Blackboard, or by emailing wcmsupport@blackboard.com.
Posted Feb 19, 2021 - 15:40 EST
This incident affected: Americas (Web Community Manager (formerly Schoolwires)).