Safe assign - Performance Issue - Global
Incident Report for Blackboard Inc.
Resolved
This incident has been resolved.
Posted Oct 25, 2024 - 12:27 EDT
Update
Papers are being reprocessed today (October 25) as part of the maintenance deployment. Progress updates for the deployment are available here: https://status.blackboard.com/incidents/tq94qjmjwbjq
Posted Oct 25, 2024 - 10:39 EDT
Update
Remaining papers will be reprocessed on Friday (October 25) as part of the maintenance deployment. Progress updates for the deployment will be available here: https://status.blackboard.com/incidents/tq94qjmjwbjq
Posted Oct 24, 2024 - 19:57 EDT
Update
Reprocessing of records has completed for an additional selected group. The remaining papers will be reprocessed on Friday (October 25) as part of the maintenance deployment.
Posted Oct 24, 2024 - 10:38 EDT
Update
Reprocessing of records has completed for a selected group. For the remaining papers, those will be reprocessed on Friday (October 25) as part of the maintenance deployment.
Posted Oct 23, 2024 - 18:35 EDT
Update
The development team continues to actively work on reprocessing records for affected clients. Further updates will be provided as they become available.
Posted Oct 23, 2024 - 12:38 EDT
Update
The development team is actively working on reprocessing the records, a portion of submitted papers will be processed part of upcoming production deployment.
Posted Oct 23, 2024 - 01:10 EDT
Update
The environment is stable. After additional validation review of records, the team has begun reprocessing papers for the impacted clients during the degradation of service.
Posted Oct 22, 2024 - 18:29 EDT
Update
The environment is stable. Validation process was successfully completed for a few reprocessed records. The team will begin reprocessing papers for the impacted clients during the degradation of service.
Posted Oct 22, 2024 - 11:26 EDT
Update
The environment is stable, reprocessing is done for few records and the validation is in progress. based on the validation results, the team will continue reprocessing the papers for the impacted clients during the degradation of service.
Posted Oct 22, 2024 - 02:24 EDT
Update
Our team is continuing to work on reprocessing of papers for the impacted clients during the degradation of service.
Posted Oct 21, 2024 - 21:34 EDT
Update
The identified issue has been resolved. Our team is now working on reprocessing of papers for the impacted clients during the degradation of service.
Posted Oct 21, 2024 - 15:23 EDT
Monitoring
We have deployed some further fixes and are seeing improvements. We are continuing to monitor the results.
Posted Oct 21, 2024 - 09:13 EDT
Update
A fix is being implemented and we are hopeful that this mitigation will significantly improve the problem. We will provide another update by 9:15 AM EDT.
Posted Oct 21, 2024 - 08:17 EDT
Update
Our Technical Team is continuing to engage and they are employing all measures to work on the fix. We will provide an update within the next 60 minutes or sooner if we have additional information to share.
Posted Oct 21, 2024 - 07:03 EDT
Update
We are continuing to work on a fix for this issue. We will share the ETA once it is available.
We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 21, 2024 - 06:00 EDT
Update
We are continuing to work on a fix for this issue. We will provide another update by 6:00 AM EDT.
Posted Oct 21, 2024 - 04:02 EDT
Update
The cause of the issue has been identified. We are actively working on multiple parallel paths to mitigate this issue. We will provide another update by 4:00 AM EDT.
Posted Oct 21, 2024 - 02:44 EDT
Identified
Our dedicated team is already actively addressing the performance issue. We are employing all measures to swiftly diagnose and rectify the issues. We understand the importance of uninterrupted service and sincerely apologize for any inconvenience this might cause.
Posted Oct 21, 2024 - 01:32 EDT
Update
We are actively working on multiple parallel paths to mitigate this issue. We will provide another update within 60 minutes or as soon as more information becomes available.
Posted Oct 21, 2024 - 00:16 EDT
Update
Our engineers are continuing to work towards a fix for this performance issue.
Posted Oct 20, 2024 - 23:44 EDT
Investigating
Few users are facing performance issue while accessing Safe assign . Our technical teams are investigating this issue.
Posted Oct 20, 2024 - 23:11 EDT
This incident affected: Global (SafeAssign).